donpappaのlinuxメモ(仮)

予備知識ほとんど無しの素人がリナックス試してみた時のメモのようなものです。

Lubuntu14.04 RadioTrayエラー

ネットラジオを聴くときはウェブブラウザでも聴けるけど処理の軽い専用視聴ソフトを使いたいと思って試した時のメモ。

NHKらじる★らじるを聴くための設定で苦戦した。

 

まずは、パッケージマネージャから「RadioTray」で検索してインストール。

プリセットされてるラジオは聴けるが、新たに設定した日本のネットラジオはエラーが出て聴けなかった。

 

ラジオエラー

gstdecodebin2.c(3576): gst_decode_bin_expose ():/
GstPlayBin2:player/GstURIDecodeBin:uridecodebin3/
GstDecodeBin2:decodebin23:
no suitable plugins found

「uridecodebin3/」や「decodebin23」の部分は数回試すと微妙に末尾の数字が変わってた。

 

ネット検索して見つけたページの情報を元に、パッケージマネージャから「gstreamer」で検索して、「gstreamer pluguins」の「good」「bad」「ugly」の3つをインストール。

 

さらにffmpegも必要ぽいので、

 端末で「sudo apt-get install ffmpeg」と打ち込むと

「パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
パッケージ ffmpeg はデータベースには存在しますが、利用できません。
おそらく、そのパッケージが見つからないか、もう古くなっているか、
あるいは別のソースからのみしか利用できないという状況が考えられます」

 という表示でインストールできなかった。

 

ネット検索するとffmpegは公式のリポジトリからインストールできなくなったようなので、自分で追加してからインストールするしかない模様。

 

端末から

$ sudo add-apt-repository ppa:mc3man/trusty-media
$ sudo apt-get update
$ sudo apt-get install ffmpeg

の順に入力していってffmpegをインストール。

追加で84MBくらいの容量が消費されるよ~って表示され、さらにソフトウェアの更新も発動。

インストールが完了するも同じエラーで聴けなかった。

 

パッケージマネージャから追加でgstreamerの0.10と1.0のgood/bad/uglyを色々インストールしてみると聴けるようになった。

結局どのパッケージをインストールすることによって聴けるようになったのか、よく分からなかった。ffmpegは必要なかったのかも?

何にせよ聴けるようになってよかった。

 

後はradjiotrayの設定からurlを登録すればおk。

 

設定したネットラジオのurl

OTTAVA http://live.leanstream.co/RKT001-MP3

NHKラジオ第1放送 http://mfile.akamai.com/129931/live/reflector:46032.asx
NHKラジオ第2放送 http://mfile.akamai.com/129932/live/reflector:46056.asx
NHK-FM放送 http://mfile.akamai.com/129933/live/reflector:46051.asx

 

OTTAVAは近々urlが変わるかもしれないらしい。

 

参考にしたページ

[SOLVED] Radio Tray ubuntuフォーラム radiotrayのエラーについて

Ubuntu ラジオトレイ その1 - 概要とインストール・インジケーターメニューについて - Ubuntu kledgeb ラジオトレイ全般

Ubuntu 14.04にffmpegをインストールしてWinFFに設定する | Ubuntuアプリのいいところ ffmpegのインストール

News(ネットワークオーディオ) | OTTAVA url関係

Ubuntu ラジオトレイ その7 - らじる★らじるを登録してNHKラジオを聞けるようにする - Ubuntu kledgeb url関係